FXs Pack VST/VSTI for Pentium 4 or higher/AMD  with SSE support, 2 GHz, 1 GB RAM, Windows XP or higher and VST compatible 32 bit host softwares
© Tekky Synths 2016
FXs Pack